summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTim Dettmers <tim.dettmers@gmail.com>2022-07-31 19:41:56 -0700
committerTim Dettmers <tim.dettmers@gmail.com>2022-07-31 19:41:56 -0700
commit28d1e7dc016b72b47dd97ee35094a98d1467cab4 (patch)
tree6ba3645d43c4582a50f4d34e446879de2a0ac596 /setup.py
parentdd50382b3237897d336f2c8f7b7f555b3c851abb (diff)
Initial build script changes (untested on PyPi).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3292e30..eefc6df 100644
--- a/setup.py
+++ b/setup.py
@@ -6,6 +6,15 @@ import os
from setuptools import setup, find_packages
+import os
+
+def all_libs(directory):
+ paths = []
+ for (path, directories, filenames) in os.walk(directory):
+ for filename in filenames:
+ paths.append(os.path.join('..', path, filename))
+ return paths
+
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
@@ -15,7 +24,7 @@ prefix = '' if version == 'cpu' else 'cuda'
setup(
name=f"bitsandbytes-{prefix}{version}",
- version=f"0.30.0",
+ version=f"0.30.2",
author="Tim Dettmers",
author_email="dettmers@cs.washington.edu",
description="8-bit optimizers and matrix multiplication routines.",
@@ -26,7 +35,7 @@ setup(
entry_points={
"console_scripts": ["debug_cuda = bitsandbytes.debug_cli:cli"],
},
- package_data={'': ['libbitsandbytes.so']},
+ package_data={'': ['libbitsandbytes*.so']},
long_description=read('README.md'),
long_description_content_type='text/markdown',
classifiers=[