summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTim Dettmers <TimDettmers@users.noreply.github.com>2022-07-18 09:51:37 -0700
committerGitHub <noreply@github.com>2022-07-18 09:51:37 -0700
commit4cd7ea62b2f51c68aacde2f62e7141765e476111 (patch)
tree548b2e77c62acd152330e898a6e17ea949a156d1 /setup.py
parent3418cd390e952a7752fb6b2544c25e25af7c0371 (diff)
parentfd750cd2370b3b12e216a9148b23aaae63a80989 (diff)
Merge pull request #3 from TimDettmers/cpuonly
Add a CPU-only build option
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 11 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 59cd78e..2402c02 100644
--- a/setup.py
+++ b/setup.py
@@ -6,27 +6,27 @@ import os
from setuptools import setup, find_packages
-
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
+version = os.getenv("CUDA_VERSION", "cpu")
+
setup(
- name = f"bitsandbytes-cuda{os.environ['CUDA_VERSION']}",
- version = "0.26.0",
- author = "Tim Dettmers",
- author_email = "dettmers@cs.washington.edu",
- description = ("8-bit optimizers and quantization routines."),
- license = "MIT",
- keywords = "gpu optimizers optimization 8-bit quantization compression",
- url = "http://packages.python.org/bitsandbytes",
+ name="bitsandbytes",
+ version=f"0.26.0+{version}",
+ author="Tim Dettmers",
+ author_email="dettmers@cs.washington.edu",
+ description="8-bit optimizers and quantization routines.",
+ license="MIT",
+ keywords="gpu optimizers optimization 8-bit quantization compression",
+ url="http://packages.python.org/bitsandbytes",
packages=find_packages(),
package_data={'': ['libbitsandbytes.so']},
long_description=read('README.md'),
- long_description_content_type = 'text/markdown',
+ long_description_content_type='text/markdown',
classifiers=[
"Development Status :: 4 - Beta",
'Topic :: Scientific/Engineering :: Artificial Intelligence'
],
)
-