summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTim Dettmers <tim.dettmers@gmail.com>2022-07-26 19:38:01 -0700
committerTim Dettmers <tim.dettmers@gmail.com>2022-07-26 19:38:01 -0700
commit5737f2b027a1e0ec8540a3aa914632d44ad9c62d (patch)
treeb288c905eaba75dc6b43a8bcebc82720c16e4816 /setup.py
parent47a73d94c3d3284f6073b0ff189ed5bc9e3a8762 (diff)
parentdc8c9efdb33130f960adc864916b67d0cb744dbb (diff)
Merge branch 'patch_merge' into extract_outliers
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 2402c02..6275ddd 100644
--- a/setup.py
+++ b/setup.py
@@ -11,13 +11,14 @@ def read(fname):
version = os.getenv("CUDA_VERSION", "cpu")
+prefix = '' if version == 'cpu' else 'cuda'
setup(
- name="bitsandbytes",
- version=f"0.26.0+{version}",
+ name=f"bitsandbytes-{prefix}{version}",
+ version=f"0.30.0",
author="Tim Dettmers",
author_email="dettmers@cs.washington.edu",
- description="8-bit optimizers and quantization routines.",
+ description="8-bit optimizers and matrix multiplication routines.",
license="MIT",
keywords="gpu optimizers optimization 8-bit quantization compression",
url="http://packages.python.org/bitsandbytes",