summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTim Dettmers <tim.dettmers@gmail.com>2021-10-05 19:16:20 -0700
committerTim Dettmers <tim.dettmers@gmail.com>2021-10-05 19:16:20 -0700
commit7439924891496025edf60c9da6a782f362a50c70 (patch)
tree90476984d2c267f89232577a2ea40eb172387475 /setup.py
Initial commit
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..dc1eb60
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,32 @@
+# Copyright (c) Facebook, Inc. and its affiliates.
+#
+# This source code is licensed under the MIT license found in the
+# LICENSE file in the root directory of this source tree.
+import os
+from setuptools import setup, find_packages
+
+
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+
+setup(
+ name = f"bitsandbytes-cuda{os.environ['CUDA_VERSION']}",
+ version = "0.0.23",
+ author = "Tim Dettmers",
+ author_email = "tim.dettmers@gmail.com",
+ description = ("Numpy-like library for GPUs."),
+ license = "MIT",
+ keywords = "gpu",
+ url = "http://packages.python.org/bitsandbytes",
+ packages=find_packages(),
+ package_data={'': ['libbitsandbytes.so']},
+ long_description=read('README.md'),
+ long_description_content_type = 'text/markdown',
+ classifiers=[
+ "Development Status :: 1 - Planning",
+ 'Topic :: Scientific/Engineering :: Artificial Intelligence'
+ ],
+)
+