summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTitus von Koeller <titus@vonkoeller.com>2022-08-01 03:31:48 -0700
committerTitus von Koeller <titus@vonkoeller.com>2022-08-01 03:31:48 -0700
commitbfa0e33294f2b1dc25e65a33be2397f989824298 (patch)
tree396b5d722fdd79da068882ca7376e3636fcb3bb8 /setup.py
parent597a8521b29e90958c31e47421016494da998648 (diff)
ran black and isort for coherent code formatting
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 13 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 965817d..3285ba1 100644
--- a/setup.py
+++ b/setup.py
@@ -1,19 +1,21 @@
-# Copyright (c) Facebook, Inc. and its affiliates.
-#
-# This source code is licensed under the MIT license found in the
+# Copyright (c) Facebook, Inc. and its affiliates.
+#
+# This source code is licensed under the MIT license found in the
# LICENSE file in the root directory of this source tree.
-import os
import glob
-from setuptools import setup, find_packages
+import os
+from setuptools import find_packages, setup
-libs = list(glob.glob('./bitsandbytes/libbitsandbytes*.so'))
+libs = list(glob.glob("./bitsandbytes/libbitsandbytes*.so"))
libs = [os.path.basename(p) for p in libs]
-print('libs:', libs)
+print("libs:", libs)
+
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
setup(
name=f"bitsandbytes",
version=f"0.31.0",
@@ -27,11 +29,11 @@ setup(
entry_points={
"console_scripts": ["debug_cuda = bitsandbytes.debug_cli:cli"],
},
- package_data={'': libs},
- long_description=read('README.md'),
- long_description_content_type='text/markdown',
+ package_data={"": libs},
+ long_description=read("README.md"),
+ long_description_content_type="text/markdown",
classifiers=[
"Development Status :: 4 - Beta",
- 'Topic :: Scientific/Engineering :: Artificial Intelligence'
+ "Topic :: Scientific/Engineering :: Artificial Intelligence",
],
)