summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTim Dettmers <tim.dettmers@gmail.com>2022-07-26 10:32:22 -0700
committerTim Dettmers <tim.dettmers@gmail.com>2022-07-26 10:32:22 -0700
commitdc8c9efdb33130f960adc864916b67d0cb744dbb (patch)
tree5fc5063cb5f4cacefdb3f81185fb8b5e5da66cba /setup.py
parent953b7285ddf55913732bc9f137953dd00ac64c35 (diff)
Changed setup.py; deployed on test pypi.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 6cc091b..6275ddd 100644
--- a/setup.py
+++ b/setup.py
@@ -11,13 +11,14 @@ def read(fname):
version = os.getenv("CUDA_VERSION", "cpu")
+prefix = '' if version == 'cpu' else 'cuda'
setup(
- name="bitsandbytes",
+ name=f"bitsandbytes-{prefix}{version}",
version=f"0.30.0",
author="Tim Dettmers",
author_email="dettmers@cs.washington.edu",
- description="8-bit optimizers and quantization routines.",
+ description="8-bit optimizers and matrix multiplication routines.",
license="MIT",
keywords="gpu optimizers optimization 8-bit quantization compression",
url="http://packages.python.org/bitsandbytes",