summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 19 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 6275ddd..cec4982 100644
--- a/setup.py
+++ b/setup.py
@@ -1,21 +1,24 @@
-# Copyright (c) Facebook, Inc. and its affiliates.
-#
-# This source code is licensed under the MIT license found in the
+# Copyright (c) Facebook, Inc. and its affiliates.
+#
+# This source code is licensed under the MIT license found in the
# LICENSE file in the root directory of this source tree.
+import glob
import os
-from setuptools import setup, find_packages
+
+from setuptools import find_packages, setup
+
+libs = list(glob.glob("./bitsandbytes/libbitsandbytes*.so"))
+libs = [os.path.basename(p) for p in libs]
+print("libs:", libs)
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
-version = os.getenv("CUDA_VERSION", "cpu")
-prefix = '' if version == 'cpu' else 'cuda'
-
setup(
- name=f"bitsandbytes-{prefix}{version}",
- version=f"0.30.0",
+ name=f"bitsandbytes",
+ version=f"0.31.1",
author="Tim Dettmers",
author_email="dettmers@cs.washington.edu",
description="8-bit optimizers and matrix multiplication routines.",
@@ -23,11 +26,14 @@ setup(
keywords="gpu optimizers optimization 8-bit quantization compression",
url="http://packages.python.org/bitsandbytes",
packages=find_packages(),
- package_data={'': ['libbitsandbytes.so']},
- long_description=read('README.md'),
- long_description_content_type='text/markdown',
+ entry_points={
+ "console_scripts": ["debug_cuda = bitsandbytes.debug_cli:cli"],
+ },
+ package_data={"": libs},
+ long_description=read("README.md"),
+ long_description_content_type="text/markdown",
classifiers=[
"Development Status :: 4 - Beta",
- 'Topic :: Scientific/Engineering :: Artificial Intelligence'
+ "Topic :: Scientific/Engineering :: Artificial Intelligence",
],
)