summaryrefslogtreecommitdiff
path: root/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/home.nix b/home.nix
index e45a3d9..f671553 100644
--- a/home.nix
+++ b/home.nix
@@ -109,13 +109,19 @@
"fugitive"
];
settings = {
- background = "light";
ignorecase = true;
expandtab = true;
history = 1000;
tabstop = 4;
};
extraConfig = ''
+ " Auto-switch theme
+ let hour = strftime("%H")
+ if 6 <= hour && hour < 18
+ set background=light
+ else
+ set background=dark
+ endif
colorscheme solarized
filetype plugin indent on
set cuc cul " Crosshair