summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/common.nix b/lib/common.nix
index 5c923ae..e9c270e 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -148,6 +148,12 @@ in
done
cd "$P"
}
+ function ff() {
+ find . -iname "*$@*" -not -path "*.git*"
+ }
+ function regex {
+ gawk 'match($0,/'$1'/, ary) {print ary['\$\{2:-'0'}']}';
+ }
# my prompt, after much chagrin
export PS1="\n\[\e[34m\][\u@\h:\w]\[\e[m\] \$(date +%Y.%m.%d..%H.%M) \$(if [ \$? == 0 ]; then true; else echo \(\$?\); fi) \n$ "
'';