summaryrefslogtreecommitdiff
path: root/lib/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/linux.nix')
-rw-r--r--lib/linux.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/linux.nix b/lib/linux.nix
index 7da8c2f..a4af6c2 100644
--- a/lib/linux.nix
+++ b/lib/linux.nix
@@ -2,7 +2,9 @@
let
inherit (import ./const.nix) fontSize homedir gpgid;
- hostname = lib.strings.removeSuffix "\n" (builtins.readFile /etc/hostname);
+ getHostname = pkgs.runCommand "hostname" {}
+ "${pkgs.hostname}/bin/hostname > $out";
+ hostname = lib.strings.removeSuffix "\n" (builtins.readFile "${getHostname}");
base16-scheme = "atelier-sulphurpool";
base16-scheme-filename = lib.strings.concatStrings (lib.strings.splitString "-" base16-scheme);
theme = lib.removeSuffix "\n" (builtins.readFile "${homedir}/.local/share/xtheme");
@@ -84,7 +86,8 @@ in
pavucontrol
pinentry
tdesktop
- tor-browser-bundle-bin
+ # texlive.combined.scheme-full
+ #tor-browser-bundle-bin
usbutils
vlc
xbindkeys