summaryrefslogtreecommitdiff
path: root/machines/helium.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/helium.nix')
-rw-r--r--machines/helium.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/machines/helium.nix b/machines/helium.nix
index 9c75b18..f8850cb 100644
--- a/machines/helium.nix
+++ b/machines/helium.nix
@@ -143,17 +143,21 @@ in {
buildMachines = [
{
+ hostName = "192.168.1.42";
+ sshUser = "ben";
+ sshKey = "/home/ben/.ssh/id_rsa";
+ system = "x86_64-linux";
+ }
+ {
hostName = "dev.simatime.com";
- sshUser = "root";
+ sshUser = "ben";
sshKey = "/home/ben/.ssh/id_rsa";
system = "x86_64-linux";
- maxJobs = 4;
- speedFactor = 4;
- #supportedFeatures = [ ];
- #mandatoryFeatures = [ ];
}
+
];
distributedBuilds = true;
+ trustedUsers = [ "root" "ben" ];
};
# This value determines the NixOS release with which your system is to be