summaryrefslogtreecommitdiff
path: root/machines/oxygen.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/oxygen.nix')
-rw-r--r--machines/oxygen.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/machines/oxygen.nix b/machines/oxygen.nix
index 4aa933e..7630436 100644
--- a/machines/oxygen.nix
+++ b/machines/oxygen.nix
@@ -13,7 +13,7 @@ let
owner = "drduh";
repo = "YubiKey-Guide";
rev = "fe6434577bce964aefd33d5e085d6ac0008e17ce";
- sha256 = lib.fakeSha256;
+ sha256 = "1f4sqj2nspv6939p3gj2ma4fnbz12l95kcr3bjzphjdgxkdx42hx";
};
buildInputs = [ pkgs.pandoc ];
installPhase = "pandoc --highlight-style pygments -s --toc README.md -o $out";
@@ -32,7 +32,6 @@ in {
isoImage.makeUsbBootable = true;
users.users.root.initialHashedPassword = "";
- services.getty.autologinUser = "root";
documentation.enable = true;
documentation.nixos.enable = true;
@@ -119,6 +118,7 @@ in {
services.xserver.displayManager.sddm.enable = true;
services.xserver.displayManager.autoLogin.enable = true;
+ services.xserver.displayManager.autoLogin.user = "root";
services.xserver.displayManager.defaultSession = "xfce";
services.xserver.displayManager.sessionCommands = ''
${pkgs.midori}/bin/midori ${guide} &
@@ -134,13 +134,14 @@ in {
powerManagement.enable = false;
- nix.useSandbox = true;
nix.nixPath = [
"nixpkgs=${nixpkgs}"
"nixos-config=/etc/nixos/configuration.nix"
"/nix/var/nix/profiles/per-user/root/channels"
];
- nix.binaryCaches = [ ];
+ nix.useSandbox = true;
+ nix.buildMachines = [ ];
+
system.extraSystemBuilderCmds = "ln -sv ${pkgs.path} $out/nixpkgs";
environment.etc.host-nix-channel.source = pkgs.path;