summaryrefslogtreecommitdiff
path: root/profiles/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/darwin.nix')
-rw-r--r--profiles/darwin.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/profiles/darwin.nix b/profiles/darwin.nix
new file mode 100644
index 0000000..c221e9e
--- /dev/null
+++ b/profiles/darwin.nix
@@ -0,0 +1,43 @@
+{ pkgs, ... }:
+
+let
+ homedir = builtins.getEnv "HOME";
+ haskellOverlay = self: super: {
+ haskellPackages = super.haskellPackages.override (old: {
+ overrides = self: super: {
+ hledger = self.callPackage ./pkgs/hledger-1.19.1.nix {};
+ hledger-lib = self.callPackage ./pkgs/hledger-lib-1.19.1.nix {};
+ };
+ });
+ };
+in
+{
+ nixpkgs.overlays = [
+ haskellOverlay
+ ];
+
+ imports = [
+ ./lib/common.nix
+ ./lib/email.nix
+ ];
+ home = {
+ sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
+ packages = with pkgs; [
+ muchsync
+ (haskellPackages.ghcWithPackages (ps: with ps; [hledger]))
+ coreutils
+ ];
+ };
+
+ programs = {
+
+ # Doesnt' work bc clang can't compile it??
+ #qutebrowser = {
+ # enable = true;
+ # settings = {
+ # "colors.webpage.darkmode.enabled" = true;
+ # };
+ #};
+
+ };
+}