summaryrefslogtreecommitdiff
path: root/profiles/groq.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/groq.nix')
-rw-r--r--profiles/groq.nix73
1 files changed, 73 insertions, 0 deletions
diff --git a/profiles/groq.nix b/profiles/groq.nix
new file mode 100644
index 0000000..d1214b3
--- /dev/null
+++ b/profiles/groq.nix
@@ -0,0 +1,73 @@
+{ pkgs, ... }:
+
+let
+ gitCommitTemplate = ./git-commit-template;
+in
+{
+ imports = [
+ ./common.nix
+ ];
+
+ accounts = {
+ email = {
+ maildirBasePath = "mail";
+ accounts = {
+ "groq" = {
+ primary = true;
+ flavor = "gmail.com";
+ realName = "Ben Sima";
+ address = "bsima@groq.com";
+ userName = "bsima@groq.com";
+ mbsync = {
+ enable = true;
+ create = "both";
+ expunge = "none";
+ };
+ notmuch.enable = true;
+ msmtp.enable = true;
+ passwordCommand = "secret-tool lookup email bsima@groq.io";
+ };
+ };
+ };
+ };
+
+ services.emacs.enable = true;
+
+ programs = {
+ emacs = {
+ enable = true;
+ };
+
+ git = {
+ enable = true;
+ userName = "Ben Sima";
+ userEmail = "bsima@groq.com";
+ ignores = [ "*~" "*.swp" ];
+ package = pkgs.gitAndTools.gitFull;
+ extraConfig = ''
+ [push]
+ default = simple
+
+ [commit]
+ template = ${gitCommitTemplate}
+ '';
+ };
+
+ mbsync.enable = true;
+ msmtp.enable = true;
+
+ notmuch = {
+ enable = true;
+ new.tags = ["new"];
+ hooks = {};
+ extraConfig.search.exclude_tags = "deleted;spam;";
+ };
+
+ alot = {
+ enable = true;
+ extraConfig = ''
+ theme = solarized_light
+ '';
+ };
+ };
+}