summaryrefslogtreecommitdiff
path: root/profiles/laptop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/laptop.nix')
-rw-r--r--profiles/laptop.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/profiles/laptop.nix b/profiles/laptop.nix
index e7096cb..c1eab46 100644
--- a/profiles/laptop.nix
+++ b/profiles/laptop.nix
@@ -71,4 +71,47 @@
};
};
};
+
+ services.betterlockscreen.enable = true;
+
+ services.picom = {
+ enable = true;
+ experimentalBackends = true;
+ backend = "glx";
+ vSync = true;
+
+ # Transparency/Opacity
+ inactiveOpacity = 0.80;
+ activeOpacity = 0.95;
+ opacityRules = [
+ "100:class_g *?= 'Firefox'"
+ "100:class_g *?= 'Deadd-notification-center'"
+ "100:class_g *?= 'Rofi'"
+ ];
+
+ # Fading
+ fade = true;
+ fadeDelta = 5;
+
+ # Shadows
+ shadowExclude = [
+ "class_g = 'eww-topbar-btw'"
+ ];
+
+ settings = {
+ # Blur
+ blur-method = "dual_kawase";
+ blur-strength = 8;
+ blur-backgroud-exclude = [
+ "class_g = 'eww-topbar-btw'"
+ ];
+
+ # Radius
+ corner-radius = 10;
+ round-borders = 1;
+ rounded-corners-exclude = [
+ "class_g = 'Custom-taffybar'"
+ ];
+ };
+ };
}