summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Comms/Mumble.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-04-24 15:11:15 -0400
committerBen Sima <ben@bsima.me>2023-04-28 08:05:28 -0400
commit02b2d3fa43bbfd8002fc6271f54a3d09e74b7cc4 (patch)
tree57c7ddda9f6f42f821f95368960910d1a3816e63 /Biz/Cloud/Comms/Mumble.nix
parente78c58ef9d2d89dea91c40251dd93404d182e8fd (diff)
Reorganize to Biz/Cloud/Comms
Diffstat (limited to 'Biz/Cloud/Comms/Mumble.nix')
-rw-r--r--Biz/Cloud/Comms/Mumble.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/Biz/Cloud/Comms/Mumble.nix b/Biz/Cloud/Comms/Mumble.nix
new file mode 100644
index 0000000..fed305e
--- /dev/null
+++ b/Biz/Cloud/Comms/Mumble.nix
@@ -0,0 +1,28 @@
+{ config, pkgs, ... }:
+
+# mumble and related services
+let
+ ports = import ../Ports.nix;
+in {
+ services.murmur = {
+ enable = true;
+ openFirewall = true;
+ environmentFile = "/var/lib/murmur/murmurd.env";
+ registerHostname = config.networking.domain;
+ registerName = config.networking.domain;
+ };
+
+ services.botamusique = {
+ enable = true;
+ settings = {
+ webinterface = {
+ enabled = true;
+ listening_addr = "127.0.0.1";
+ listening_port = ports.botamusique;
+ };
+ radio = {
+ lofi = "https://live.hunter.fm/lofi_high";
+ };
+ };
+ };
+}