summaryrefslogtreecommitdiff
path: root/Biz/Dev/Configuration.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-12-29 22:29:57 -0500
committerBen Sima <ben@bsima.me>2020-12-29 22:29:57 -0500
commit36eac84f40aa938fd9327ddf4f983736ff550bcf (patch)
tree75da57d82a42e5039227ac8605b004e8e251a6c4 /Biz/Dev/Configuration.nix
parentb11e926cf60672c17b462ad142014946063f4136 (diff)
Deploy hoogle to Biz.Dev
I had to refactor Biz/Bild/Rules.nix. I also had to checkin my patched hoogle.nix file, but I also upstreamed the patch to nixpkgs-dev so it shouldn't stick around for too long.
Diffstat (limited to 'Biz/Dev/Configuration.nix')
-rw-r--r--Biz/Dev/Configuration.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/Biz/Dev/Configuration.nix b/Biz/Dev/Configuration.nix
index 24293cf..13be1be 100644
--- a/Biz/Dev/Configuration.nix
+++ b/Biz/Dev/Configuration.nix
@@ -8,6 +8,7 @@ let
jellyfin = 8096;
httpdev = { from = 8000; to = 8099; };
devallocHost = 8095;
+ hoogle = 8008;
};
in {
networking = {
@@ -109,6 +110,15 @@ in {
};
services = {
+ my-hoogle = {
+ enable = true;
+ port = ports.hoogle;
+ home = "//hoogle.simatime.com";
+ packages = import ../Bild/Deps/Haskell.nix;
+ haskellPackages = pkgs.haskell.packages.ghc865;
+ host = "0.0.0.0";
+ };
+
pcscd.enable = true;
logind = {
lidSwitch = "ignore";
@@ -223,7 +233,6 @@ in {
nixos.enable = true;
};
-
nix = {
autoOptimiseStore = true;
buildCores = 0; # use all available cores