summaryrefslogtreecommitdiff
path: root/Biz/Dev/Configuration.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-10-17 11:52:47 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:38 -0500
commitf432b7057738cb5123c8e1b506a2a1199e71ee72 (patch)
treef9a1f2eda099530934ea1f56d58ea08ba25e304b /Biz/Dev/Configuration.nix
parent8e1340bda701171e3557840332c4f3c30e1afc28 (diff)
Update cloud services
Rebuilt email server, started wireguard setup.
Diffstat (limited to 'Biz/Dev/Configuration.nix')
-rw-r--r--Biz/Dev/Configuration.nix22
1 files changed, 14 insertions, 8 deletions
diff --git a/Biz/Dev/Configuration.nix b/Biz/Dev/Configuration.nix
index 2dcc816..8eb4958 100644
--- a/Biz/Dev/Configuration.nix
+++ b/Biz/Dev/Configuration.nix
@@ -5,7 +5,7 @@ let
ports = import ../Cloud/Ports.nix;
in {
networking = {
- nameservers = [ "1.1.1.1" "8.8.8.8" ];
+ nameservers = [ "1.1.1.1" ];
hostName = "lithium";
hosts = {
"::1" = [ "localhost" "ipv6-localhost" "ipv6-loopback" ];
@@ -13,17 +13,22 @@ in {
firewall = {
allowedTCPPorts = [
- 22 8000 8443 443 # standard ports
- 500 10000 # no idea
- ports.jellyfin
+ ports.bitcoind
ports.delugeWeb
- ports.murmur
+ ports.et
+ ports.gemini
+ ports.git
+ ports.http
+ ports.https
+ ports.jellyfin
+ ports.jupyter
ports.mpd
ports.mpd-stream
+ ports.murmur
+ ports.radicale
+ ports.sabten
+ ports.ssh
ports.tor
- ports.et
- ports.bitcoind
- ports.jupyter
];
allowedTCPPortRanges = [
ports.torrents
@@ -61,6 +66,7 @@ in {
environment.systemPackages = [
pkgs.wemux
pkgs.tmux
+ pkgs.wireguard
];
nixpkgs = {