summaryrefslogtreecommitdiff
path: root/Com/Simatime/networking.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-02 23:45:04 -0700
committerBen Sima <ben@bsima.me>2020-04-02 23:45:04 -0700
commit65c2b30a288385cf3df4027d50080ac595bbcf83 (patch)
tree391aa2ea046935e4bd5463abf8979633697b99f5 /Com/Simatime/networking.nix
parent4ef954f7b3e9b5d99d1030843c2633dbd76f37c0 (diff)
Reorganize and comment some of the nix code
Diffstat (limited to 'Com/Simatime/networking.nix')
-rw-r--r--Com/Simatime/networking.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/Com/Simatime/networking.nix b/Com/Simatime/networking.nix
deleted file mode 100644
index 60d8ebf..0000000
--- a/Com/Simatime/networking.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{ lib, config, ... }:
-
-{
- networking = {
- hostName = "simatime";
- domain = "simatime.com";
- firewall = {
- allowedTCPPorts = [ 22 80 443 ];
- allowPing = true;
- };
-
- # This following was populated at runtime with the networking details
- # gathered from the active system.
- nameservers = [
- "67.207.67.2"
- "67.207.67.3"
- ];
- defaultGateway = "159.89.128.1";
- defaultGateway6 = "";
- dhcpcd.enable = false;
- usePredictableInterfaceNames = lib.mkForce true;
- interfaces = {
- eth0 = {
- ipv4.addresses = [
- { address="159.89.128.69"; prefixLength=20; }
- { address="10.46.0.6"; prefixLength=16; }
- ];
- ipv6.addresses = [
- { address="fe80::e899:c0ff:fe9c:e194"; prefixLength=64; }
- ];
- };
- };
- };
- services.udev.extraRules = ''
- ATTR{address}=="ea:99:c0:9c:e1:94", NAME="eth0"
- '';
-}