summaryrefslogtreecommitdiff
path: root/Com/Simatime/users.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-11-02 15:33:13 -0700
committerBen Sima <ben@bsima.me>2019-11-02 15:33:13 -0700
commit9d114cfc773171b0a95bd4d2c39f1bb0eb783c8d (patch)
tree20766a760ed0141cf39153565e8552f6739c632d /Com/Simatime/users.nix
parentd2a37f5de160160eadbacd7b8dc2567f78a0543d (diff)
rename everything back to caps to appease ghc
Diffstat (limited to 'Com/Simatime/users.nix')
-rw-r--r--Com/Simatime/users.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/Com/Simatime/users.nix b/Com/Simatime/users.nix
new file mode 100644
index 0000000..daac9d6
--- /dev/null
+++ b/Com/Simatime/users.nix
@@ -0,0 +1,33 @@
+{ ... }:
+
+let
+ key = f: builtins.readFile (./keys/. + ("/" + f));
+in
+{
+ users = {
+ users = {
+ # bots
+ deploy = {
+ isNormalUser = true;
+ home = "/home/deploy";
+ openssh.authorizedKeys.keys = [ (key "deploy.pub") ];
+ extraGroups = [ "wheel" ];
+ };
+
+ # humans
+ root.openssh.authorizedKeys.keys = [ (key "ben.pub") ];
+ ben = {
+ isNormalUser = true;
+ home = "/home/ben";
+ openssh.authorizedKeys.keys = [ (key "ben.pub") ];
+ extraGroups = [ "wheel" "networkmanager" "docker" ];
+ };
+ nick = {
+ isNormalUser = true;
+ home = "/home/nick";
+ openssh.authorizedKeys.keys = [ (key "nick.pub") ];
+ extraGroups = [ "docker" ];
+ };
+ };
+ };
+}