summaryrefslogtreecommitdiff
path: root/Que/Host.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-10-23 16:16:50 -0400
committerBen Sima <ben@bsima.me>2020-10-23 16:16:50 -0400
commite069bc069f998e3158c826e20f7d94575907ae46 (patch)
tree4db36b4aa87670ec36dd97ed7a0e12a09da1a764 /Que/Host.nix
parent36021097e17ab1cfa971564cb70128d704e88f2d (diff)
Rename Que.{Server,Website} -> Que.{Host,Site}
Diffstat (limited to 'Que/Host.nix')
-rw-r--r--Que/Host.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/Que/Host.nix b/Que/Host.nix
new file mode 100644
index 0000000..e326483
--- /dev/null
+++ b/Que/Host.nix
@@ -0,0 +1,46 @@
+{ options
+, lib
+, config
+, pkgs
+, modulesPath
+}:
+
+let
+ cfg = config.services.que-server;
+in
+{
+ options.services.que-server = {
+ enable = lib.mkEnableOption "Enable the que-server service";
+ port = lib.mkOption {
+ type = lib.types.int;
+ default = 3000;
+ description = ''
+ The port on which que-server will listen for
+ incoming HTTP traffic.
+ '';
+ };
+ package = lib.mkOption {
+ type = lib.types.package;
+ description = "que-server package to use";
+ };
+ };
+ config = lib.mkIf cfg.enable {
+ systemd.services.que-server = {
+ path = [ cfg.package ];
+ wantedBy = [ "multi-user.target" ];
+ script = ''
+ ${cfg.package}/bin/que-server
+ '';
+ description = ''
+ Que server
+ '';
+ serviceConfig = {
+ Environment = ["QUE_PORT=${toString cfg.port}"];
+ KillSignal = "INT";
+ Type = "simple";
+ Restart = "on-abort";
+ RestartSec = "1";
+ };
+ };
+ };
+}