summaryrefslogtreecommitdiff
path: root/Run/Que/Website.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-15 09:54:10 -0700
committerBen Sima <ben@bsima.me>2020-04-15 10:06:56 -0700
commitf4b8c0df041b063c0b47d2ec6c818a9c202fd833 (patch)
tree01ad246a83fda29c079847b3397ca6509a7f6106 /Run/Que/Website.nix
parent6ed475ca94209ce92e75f48764cb9d361029ea26 (diff)
Re-namespacing
Moving away from the DNS-driven namespacing toward more condensed names, mostly because I don't like typing so much.
Diffstat (limited to 'Run/Que/Website.nix')
-rw-r--r--Run/Que/Website.nix59
1 files changed, 0 insertions, 59 deletions
diff --git a/Run/Que/Website.nix b/Run/Que/Website.nix
deleted file mode 100644
index 6a24d9d..0000000
--- a/Run/Que/Website.nix
+++ /dev/null
@@ -1,59 +0,0 @@
-{ options
-, lib
-, config
-, pkgs
-, modulesPath
-}:
-
-let
- cfg = config.services.que-website;
- static = pkgs.stdenv.mkDerivation {
- src = ./.;
- name = "que-website-static";
- installPhase = ''
- mkdir -p $out
- cp ${./apidocs.md} $out/apidocs.md
- cp ${./index.md} $out/index.md
- cp ${./quescripts.md} $out/quescripts.md
- cp ${./style.css} $out/style.css
- cp ${./tutorial.md} $out/tutorial.md
- cp ${./client.py} $out/client.py
- '';
- };
-in
-{
- options.services.que-website = {
- enable = lib.mkEnableOption "Enable the que-website service";
- namespace = lib.mkOption {
- type = lib.types.str;
- default = "_";
- description = ''
- The que namespace on which que-website will broadcast.
- '';
- };
- package = lib.mkOption {
- type = lib.types.package;
- description = "que-website package to use";
- };
- };
- config = lib.mkIf cfg.enable {
- systemd.services.que-website = {
- path = [ cfg.package pkgs.pandoc ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- ${cfg.package}/bin/que-website ${static} ${cfg.namespace}
- '';
- description = ''
- Que website server
- '';
- serviceConfig = {
- User = "root";
- Environment = "HOME=/root";
- KillSignal = "INT";
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "1";
- };
- };
- };
-}