summaryrefslogtreecommitdiff
path: root/Run/Que/service.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-03-31 20:50:14 -0700
committerBen Sima <ben@bsima.me>2020-03-31 20:51:59 -0700
commitcf1d92a7458313b9f3212b6d67958996341e11d4 (patch)
tree12d1ed8cbd72da75f4559e1fcd2f8d56e376c90a /Run/Que/service.nix
parent744b673f20c6993038e10a480bd746db2c1dccb3 (diff)
Finally fix guardIP
First problem was that my `extract` function wasn't working. Second problem was that nginx wasn't passing along the headers anyway.
Diffstat (limited to 'Run/Que/service.nix')
-rw-r--r--Run/Que/service.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/Run/Que/service.nix b/Run/Que/service.nix
index b9f5c19..1d82bd6 100644
--- a/Run/Que/service.nix
+++ b/Run/Que/service.nix
@@ -60,6 +60,10 @@ in
enableACME = true;
locations."/" = {
proxyPass = "http://localhost:${toString cfg.port}";
+ extraConfig = ''
+ # forward the headers so the `guardIP` function works properly
+ proxy_pass_request_headers on;
+ '';
};
};
};