summaryrefslogtreecommitdiff
path: root/Run/Que/service.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-04-05 15:53:37 -0700
committerBen Sima <ben@bsima.me>2020-04-05 15:53:37 -0700
commite5dbfd32b52e35aecf961b8b80a5f70e76c3cb83 (patch)
treed450a29f3679e815a0c47b7f37d5969f2f80247b /Run/Que/service.nix
parentf0e5894c625a726b5364365298f144e862b23676 (diff)
Deploy que.run without nginx
I still have to reimplement the SSL stuff but in the Haskell code. That seems kinda hard or at least requires research that I don't wanna do right now.
Diffstat (limited to 'Run/Que/service.nix')
-rw-r--r--Run/Que/service.nix73
1 files changed, 0 insertions, 73 deletions
diff --git a/Run/Que/service.nix b/Run/Que/service.nix
deleted file mode 100644
index aa68657..0000000
--- a/Run/Que/service.nix
+++ /dev/null
@@ -1,73 +0,0 @@
-{ options
-, lib
-, config
-, pkgs
-, modulesPath
-}:
-
-let
- cfg = config.services.que-server;
-in
-{
- options.services.que-server = {
- enable = lib.mkEnableOption "Enable the que-server service";
- domain = lib.mkOption {
- type = lib.types.str;
- default = "que.run";
- description = ''
- Domain on which to host que-server. This is passed to
- services.nginx.virtualHosts.<name> directly.
- '';
- };
- port = lib.mkOption {
- type = lib.types.int;
- default = 3000;
- description = ''
- The port on which que-server will listen for
- incoming HTTP traffic.
- '';
- };
- package = lib.mkOption {
- type = lib.types.package;
- description = "que-server package to use";
- };
- };
- config = lib.mkIf cfg.enable {
- systemd.services.que-server = {
- path = [ cfg.package ];
- wantedBy = [ "multi-user.target" ];
- script = ''
- ${cfg.package}/bin/que-server -p ${toString cfg.port}
- '';
- description = ''
- Que server
- '';
- serviceConfig = {
- KillSignal = "INT";
- Type = "simple";
- Restart = "on-abort";
- RestartSec = "1";
- };
- };
- services.nginx = {
- recommendedGzipSettings = true;
- recommendedOptimisation = true;
- recommendedProxySettings = true;
- recommendedTlsSettings = true;
- virtualHosts = {
- "${cfg.domain}" = {
- forceSSL = true;
- enableACME = true;
- locations."/" = {
- proxyPass = "http://localhost:${toString cfg.port}";
- extraConfig = ''
- proxy_set_header X-Real-IP $realip_remote_addr;
- proxy_set_header X-Forwarded-Host $remote_addr;
- proxy_pass_request_headers on;
- '';
- };
- };
- };
- };
- };
-}