diff options
author | Ben Sima <ben@bsima.me> | 2020-04-03 15:37:10 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2020-04-03 17:55:39 -0700 |
commit | e82440741295543769fa79ae05519d58fcb81b08 (patch) | |
tree | 7c63e371030947c2a1b0cb21a6687686794a2ccd /biz.nix | |
parent | 4dc2cd1369a9bea6cf0d393059b7ae3a07039f52 (diff) |
Factor haskell packages into overlays
Diffstat (limited to 'biz.nix')
-rw-r--r-- | biz.nix | 35 |
1 files changed, 1 insertions, 34 deletions
@@ -12,39 +12,6 @@ let seq = ls: builtins.filter (x: x!= null) ls; depsToPackageSet = packageSet: deps: map (s: builtins.getAttr s packageSet) deps; - - # do the build... - - claySrc = pkgs.fetchFromGitHub { - owner = "sebastiaanvisser"; - repo = "clay"; - rev = "cc7729b1b42a79e261091ff7835f7fc2a7ae3cee"; - sha256 = "1vd67976lvi5l4qq18zy6j44apynkl44ps04p8vwfx4gzr895dyp"; - }; - - ghc865_ = pkgs.haskell.packages.ghc865.override (oldAttrs: { - overrides = with pkgs.haskell.lib; self: super: { - clay = self.callCabal2nix "clay" claySrc {}; - wai-middleware-metrics = dontCheck super.wai-middleware-metrics; - }; - }); - - # ghcjs-8.6.0.1 - ghcjs_ = pkgs.haskell.packages.ghcjs.override (oldAttrs: { - overrides = with pkgs.haskell.lib; self: super: { - QuickCheck = dontCheck super.QuickCheck; - base-compat-batteries = dontCheck super.http-types; - clay = dontCheck (self.callCabal2nix "clay" claySrc {}); - comonad = dontCheck super.comonad; - http-types = dontCheck super.http-types; - network-uri= dontCheck super.network-uri; - scientific = dontCheck super.scientific; # takes forever - servant = dontCheck super.servant; - tasty-quickcheck = dontCheck super.tasty-quickcheck; - time-compat = dontCheck super.time-compat; - }; - }); - in { buildGhc = main: let @@ -57,7 +24,7 @@ in { deps = lists.flatten (seq (map (builtins.match "^-- : dep ([[:alnum:]._-]*)$") (lines content))); - ghc = ghc865_.ghcWithHoogle (hp: depsToPackageSet hp deps); + ghc = pkgs.haskell.packages.ghc865.ghcWithHoogle (hp: depsToPackageSet hp deps); in stdenv.mkDerivation { name = module; version = "0"; |