summaryrefslogtreecommitdiff
path: root/depo/users.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-09-17 21:42:15 -0700
committerBen Sima <ben@bsima.me>2019-09-17 21:45:34 -0700
commit83dfc24001e0846c9f631f3902fd7139a60439ba (patch)
tree937a666db47e2dc74483306f755ae8dfafd86a02 /depo/users.nix
parent830668f1368c0a025fe8d58fce663afc75a7f481 (diff)
[depo] enable deploy user and change password settings
Disable password authentication for ssh. We only use key-based ssh auth and don't set passwords, so this shouldn't work anyway. Also enable passwordless sudo, since we don't set passwords.
Diffstat (limited to 'depo/users.nix')
-rw-r--r--depo/users.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/depo/users.nix b/depo/users.nix
index 9093566..cd73996 100644
--- a/depo/users.nix
+++ b/depo/users.nix
@@ -8,7 +8,8 @@ in
users = {
# bots
deploy = {
- isSystemUser = true;
+ isNormalUser = true;
+ home = "/home/deploy";
openssh.authorizedKeys.keys = [ (key "deploy.pub") ];
extraGroups = [ "wheel" ];
};