summaryrefslogtreecommitdiff
path: root/modules/ibb.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-02-17 14:02:06 -0800
committerBen Sima <ben@bsima.me>2019-02-17 14:12:13 -0800
commit563bf764f0e6705ec0f5b6daf82585b8041e8056 (patch)
tree36da080306ca7281e41abc7bd48e6d0cb981898e /modules/ibb.nix
parentdc22a56185f9e2f9d955a3b314d191ea4f0e3dd1 (diff)
Move ibb module
Diffstat (limited to 'modules/ibb.nix')
-rw-r--r--modules/ibb.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/modules/ibb.nix b/modules/ibb.nix
new file mode 100644
index 0000000..e2d4dd0
--- /dev/null
+++ b/modules/ibb.nix
@@ -0,0 +1,42 @@
+{ options
+, lib
+, config
+, pkgs
+, modulesPath
+}:
+
+let
+ cfg = config.services.ibb;
+in
+{
+ options.services.ibb = {
+ enable = lib.mkEnableOption "Enable the IBB service";
+ port = lib.mkOption {
+ type = lib.types.string;
+ default = "3000";
+ description = ''
+ The port on which IBB will listen for
+ incoming HTTP traffic.
+ '';
+ };
+ };
+ config = lib.mkIf cfg.enable {
+ systemd.services.ibb = {
+ path = with pkgs; [ ibb bash ];
+ wantedBy = [ "multi-user.target" ];
+ script = ''
+ PORT=${cfg.port} ./bin/ibb
+ '';
+ description = ''
+ Influenced By Books website
+ '';
+ serviceConfig = {
+ WorkingDirectory=pkgs.ibb;
+ KillSignal="INT";
+ Type = "simple";
+ Restart = "on-abort";
+ RestartSec = "10";
+ };
+ };
+ };
+}