summaryrefslogtreecommitdiff
path: root/nix/haskell-deps.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-06-27 09:20:59 -0700
committerBen Sima <ben@bsima.me>2020-06-27 09:20:59 -0700
commit14e3c6a61f7727e994c4e1cf2568a3e606f84648 (patch)
tree6322dcfecf06bad2be8f85d560fd81e5206262e2 /nix/haskell-deps.nix
parent1ad6b3248f788cc178162bac5919c0b0fd6f9d39 (diff)
hero: implement the basics of user logins
There's also a lot of refactoring/renaming in here, so the diff is really messy. The overall problem is that I've only ever added code, I've never gone back and reorganized/rearchitected stuff. So adding even small features is becoming an enormous effort. Anyway, this adds the basics of user auth. Next I need to add the auth checks for every route that needs it, and make sure everything is back to working correctly.
Diffstat (limited to 'nix/haskell-deps.nix')
-rw-r--r--nix/haskell-deps.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nix/haskell-deps.nix b/nix/haskell-deps.nix
index 44c2050..26981dc 100644
--- a/nix/haskell-deps.nix
+++ b/nix/haskell-deps.nix
@@ -33,6 +33,8 @@
"safecopy"
"scotty"
"servant"
+ "servant-auth"
+ "servant-auth-server"
"servant-lucid"
"servant-server"
"split"
@@ -50,4 +52,5 @@
"wai-extra"
"wai-middleware-metrics"
"warp"
+ "x509"
]