summaryrefslogtreecommitdiff
path: root/pack/bs.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-10-27 09:48:52 -0700
committerBen Sima <ben@bsima.me>2019-10-27 12:14:40 -0700
commitc790672cc244ac4caba1bda3572829a6c6862891 (patch)
tree2706bb8044f7b14840c5f90f215b79b433e81045 /pack/bs.nix
parent44df4ba39f65c3afd84bee6b03f47d9b061e9038 (diff)
move everything to namespace directories
Diffstat (limited to 'pack/bs.nix')
-rw-r--r--pack/bs.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/pack/bs.nix b/pack/bs.nix
deleted file mode 100644
index d869dd1..0000000
--- a/pack/bs.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ nixpkgs }:
-with nixpkgs;
-let
- ghc = pkgs.haskell.packages.ghc844.ghcWithPackages (hp: with hp; [
- hinotify
-
- containers
- directory
- haskeline
- HTTP
- mtl
- optparse-applicative
- parsec
- protolude
- text
- transformers
- wl-pprint-text
- ]);
- entrypoint = "Bs";
-in
-stdenv.mkDerivation rec {
- name = "bs";
- version = "0";
- src = ../.;
- nativeBuildInputs = [
- ghc
- ];
- strictDeps = true;
- buildPhase = ''
- ${ghc}/bin/ghc \
- -iapex -ilore \
- -main-is ${entrypoint} --make apex/${entrypoint}.hs \
- -o bild/${name}
- '';
- installPhase = ''
- mkdir -p $out/bin
- cp bild/${name} $out/bin/${name}
- '';
-}