summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix7
1 files changed, 1 insertions, 6 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index cab8193..a4e655b 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -58,7 +58,7 @@ in rec {
set -eux
mkdir $out
: analyzing with bild
- ${bild}/bin/bild --analyze ${main} 1> $out/analysis.json 2> $out/stderr
+ ${bild}/bin/bild --json ${main} 1> $out/analysis.json 2> $out/stderr
set +eux
'';
installPhase = "exit 0";
@@ -124,11 +124,9 @@ in rec {
env = pkgs.mkShell {
name = "bizdev";
buildInputs = with nixpkgs.pkgs; [
- ghcPackageSetFull # need this until 'bild -s' works
# this should just be dev tools
haskell.packages.${ghcCompiler}.apply-refact
bild
- cmark
figlet
haskell.packages.${ghcCompiler}.fast-tags
hlint
@@ -140,14 +138,11 @@ in rec {
python38Packages.pylint
shellcheck
wemux
- gmnisrv
- gmni
] ++ lib.optional nixpkgs.stdenv.isLinux [
# scheme deps (i think these are broken on macOS)
guile
#inspekt3d
#libfive
- ccze
];
shellHook = ". ${./Bild/ShellHook.sh}";
};