summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 0391d84..dca1b3b 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -32,7 +32,7 @@ rec {
ghcPackageSetBild = private.ghcWith (hpkgs: with hpkgs; [
aeson async base bytestring conduit conduit-extra containers directory
docopt filepath process protolude rainbow regex-applicative split tasty
- tasty-hunit tasty-quickcheck text neat-interpolation
+ tasty-hunit tasty-quickcheck text hostname
wai # can remove when removed from Biz.Log
]);
@@ -50,14 +50,13 @@ rec {
# this is just to get access to ghc-pkg in bild
(private.ghcWith (hpkgs: with hpkgs; []))
- /* disable until nixified builds are complete
+ /* disable until nixified builds are complete */
rustc
# c deps
gcc gdb valgrind argp-standalone SDL
# lisp deps
guile
(private.sbclWith (p: with p; [asdf alexandria])) # just enough to build Example.lisp
- */
];
# a standard nix build for `bild` - this should be the only hand-written
@@ -75,6 +74,7 @@ rec {
${private.ghcPackageSetFull}/lib/ghc-${private.ghcPackageSetFull.version}/package.conf.d \
$out/lib/ghc-${private.ghcPackageSetFull.version}
ghc \
+ -threaded \
-Werror \
-i. \
--make Biz/Bild.hs \