summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index a51a3d0..2a049b0 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -36,7 +36,7 @@ rec {
};
# generally-useful things from nixpkgs
- inherit (nixpkgs) lib stdenv sources;
+ inherit (nixpkgs) lib stdenv sources runCommand;
# expose some packages for inclusion in os/image builds
pkgs = with nixpkgs.pkgs; [ git ];
@@ -45,14 +45,12 @@ rec {
bildRuntimeDeps = with nixpkgs; [
pkg-config
gnutls
- guile
- SDL
private.ghcPackageSetBild
rustc
- gcc
- gdb
- valgrind
- argp-standalone
+ # c deps
+ gcc gdb valgrind argp-standalone SDL
+ # lisp deps
+ guile
(private.sbclWith (p: with p; [asdf alexandria])) # just enough to build Example.lisp
];