summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 04be55f..24ce4bf 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -116,13 +116,12 @@ in nixpkgs // {
src = ../.;
USER = "nixbld";
HOSTNAME = "nix-sandbox";
- # this is the default sandbox path where bild will be working:
- CODEROOT = "/build/omni";
# we need to remove the $src root because bild expects paths relative to the
# working directory:
TARGET = "."
+ lib.strings.removePrefix (toString src) (toString target);
buildPhase = ''
+ export CODEROOT=$(pwd)
mkdir $out
${bild}/bin/bild --plan "$TARGET" 1> $out/analysis.json \
2> >(tee -a $out/stderr >&2)