summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index eb4821d..baac934 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -18,11 +18,11 @@ let
haskellDeps = import ./Bild/Deps/Haskell.nix;
- mkGhcPackageSet = nixpkgs.haskell.packages.${ghcCompiler}.ghcWithHoogle;
+ ghcWith = nixpkgs.haskell.packages.${ghcCompiler}.ghcWithHoogle;
#mkGhcjsPackageSet = nixpkgs.haskell.packages.${ghcjsCompiler}.ghcWithPackages;
- ghcPackageSetFull = mkGhcPackageSet haskellDeps;
- ghcPackageSetBild = mkGhcPackageSet (hpkgs: with hpkgs; [
+ ghcPackageSetFull = ghcWith haskellDeps;
+ ghcPackageSetBild = ghcWith (hpkgs: with hpkgs; [
aeson async base bytestring conduit conduit-extra containers directory
docopt filepath process protolude rainbow regex-applicative split tasty
tasty-hunit tasty-quickcheck text
@@ -31,7 +31,7 @@ let
in rec {
inherit (nixpkgs) lib stdenv sources;
- inherit mkGhcPackageSet;
+ inherit ghcWith;
# a standard nix build for `bild` - this should be the only hand-written
# builder we need
@@ -90,7 +90,7 @@ in rec {
ghc = main:
let
data = analyze main;
- ghc = mkGhcPackageSet (hp: selectAttrs data.langdeps hp);
+ ghc = ghcWith (hp: selectAttrs data.langdeps hp);
module = lib.strings.concatStringsSep "." data.namespace.path;
in stdenv.mkDerivation {
name = module;