summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 415931b..ca9223f 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -26,6 +26,8 @@ rec {
sbclWith = nixpkgs.lispPackages_new.sbclWithPackages;
+ pythonWith = nixpkgs.python3.withPackages;
+
ghcPackageSetFull = private.ghcWith private.haskellDeps;
ghcPackageSetBild = private.ghcWith (hpkgs: with hpkgs; [
aeson async base bytestring conduit conduit-extra containers directory
@@ -112,6 +114,8 @@ rec {
(lib.trivial.importJSON
(runBildAnalyze main + "/analysis.json"));
+ buildPythonApplication = nixpkgs.python310.pkgs.buildPythonApplication;
+
# build a ghc executable
ghc = main:
let
@@ -153,16 +157,6 @@ rec {
lolcat
#nixops # fails to build
ormolu
- (private.nixpkgs.python3.withPackages(p: with p; [
- transformers
- pytorch
- private.nixpkgs.python3Packages.bitsandbytes
- private.nixpkgs.python3Packages.accelerate
- # lint tools:
- black
- pylint
- ]))
-
shellcheck
wemux
];