summaryrefslogtreecommitdiff
path: root/Biz/Bild/Builder.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Builder.nix')
-rw-r--r--Biz/Bild/Builder.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/Biz/Bild/Builder.nix b/Biz/Bild/Builder.nix
index 8f42733..f9eb31d 100644
--- a/Biz/Bild/Builder.nix
+++ b/Biz/Bild/Builder.nix
@@ -92,16 +92,22 @@ let
python = bild.python.buildPythonApplication rec {
inherit name src BIZ_ROOT;
- propagatedBuildInputs = [ (bild.python.pythonWith (_: langdeps_)) ] ++ sysdeps_;
+ propagatedBuildInputs = langdeps_ ++ sysdeps_;
buildInputs = sysdeps_;
- checkInputs = [(bild.python.pythonWith (p: with p; [black mypy])) ruff];
+ nativeCheckInputs = [ black mypy ruff ];
checkPhase = ''
check() {
$@ || { echo "fail: $name: $3"; exit 1; }
}
+ cp ${../../pyproject.toml} ./pyproject.toml
check python -m black --quiet --exclude 'setup\.py$' --check .
check ${ruff}/bin/ruff check .
- check python -m mypy --strict --no-error-summary --exclude 'setup\.py$' .
+ touch ./py.typed
+ check python -m mypy \
+ --explicit-package-bases \
+ --no-error-summary \
+ --exclude 'setup\.py$' \
+ .
check python -m ${mainModule} test
'';
preBuild = ''