summaryrefslogtreecommitdiff
path: root/Biz/Bild/Builder.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Builder.nix')
-rw-r--r--Biz/Bild/Builder.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/Biz/Bild/Builder.nix b/Biz/Bild/Builder.nix
index f9eb31d..2ed3dd1 100644
--- a/Biz/Bild/Builder.nix
+++ b/Biz/Bild/Builder.nix
@@ -10,7 +10,7 @@ let
analysis = builtins.fromJSON analysisJSON;
build = _: target: let
name = target.out;
- root = builtins.getEnv "BIZ_ROOT";
+ root = builtins.getEnv "CODEROOT";
mainModule = target.mainModule;
compileLine =
lib.strings.concatStringsSep " " ([target.compiler] ++ target.compilerFlags);
@@ -51,18 +51,18 @@ let
else
lib.attrsets.attrVals target.sysdeps pkgs;
- BIZ_ROOT = ".";
+ CODEROOT = ".";
builders = {
base = stdenv.mkDerivation rec {
- inherit name src BIZ_ROOT preBuild;
+ inherit name src CODEROOT preBuild;
buildInputs = langdeps_ ++ sysdeps_;
installPhase = "install -D ${name} $out/bin/${name}";
buildPhase = compileLine;
};
haskell = stdenv.mkDerivation rec {
- inherit name src BIZ_ROOT preBuild;
+ inherit name src CODEROOT preBuild;
nativeBuildInputs = [ makeWrapper ];
buildInputs = sysdeps_ ++ [
(bild.haskell.ghcWith (p:
@@ -78,7 +78,7 @@ let
};
c = stdenv.mkDerivation rec {
- inherit name src BIZ_ROOT preBuild;
+ inherit name src CODEROOT preBuild;
buildInputs = langdeps_ ++ sysdeps_;
installPhase = "install -D ${name} $out/bin/${name}";
buildPhase = lib.strings.concatStringsSep " " [
@@ -91,7 +91,7 @@ let
};
python = bild.python.buildPythonApplication rec {
- inherit name src BIZ_ROOT;
+ inherit name src CODEROOT;
propagatedBuildInputs = langdeps_ ++ sysdeps_;
buildInputs = sysdeps_;
nativeCheckInputs = [ black mypy ruff ];