summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps.nix')
-rw-r--r--Biz/Bild/Deps.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Biz/Bild/Deps.nix b/Biz/Bild/Deps.nix
index 946a834..4f16250 100644
--- a/Biz/Bild/Deps.nix
+++ b/Biz/Bild/Deps.nix
@@ -1,16 +1,16 @@
self: super:
+with import ./Constants.nix;
let
buildCabal = sel: name:
sel.callCabal2nix name super.sources.${name} {};
buildCabalSubdir = sel: {name, src ? super.sources.${name}, subdir ? name}:
sel.callCabal2nix name (src + "/${subdir}") {};
- ghc = "ghc884";
in rec
{
haskell = super.haskell // {
packages = super.haskell.packages // {
- "${ghc}" = super.haskell.packages."${ghc}".override (old: {
+ "${ghcCompiler}" = super.haskell.packages."${ghcCompiler}".override (old: {
overrides = with super.pkgs.haskell.lib; sel: sup:
super.overridePinnedDeps (buildCabal sel) // {
acid-state = dontCheck sup.acid-state; # mac: "too many open files"