summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/gmni.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps/gmni.nix')
-rw-r--r--Biz/Bild/Deps/gmni.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/Biz/Bild/Deps/gmni.nix b/Biz/Bild/Deps/gmni.nix
new file mode 100644
index 0000000..092638d
--- /dev/null
+++ b/Biz/Bild/Deps/gmni.nix
@@ -0,0 +1,20 @@
+{stdenv, fetchgit, pkg-config, bearssl, scdoc}:
+
+stdenv.mkDerivation {
+ name = "gmni";
+ version = "77b73efb";
+ src = fetchgit {
+ url = "https://git.sr.ht/~sircmpwn/gmni";
+ rev = version;
+ sha256 = "1wvnzyv7vyddcd39y6q5aflpnnsdl4k4y5aj5ssb7vgkld0h1b7r";
+ };
+ nativeBuildInputs = [ pkg-config ];
+ buildInputs = [ bearssl scdoc ];
+ meta = with stdenv.lib; {
+ description = "A Gemini client";
+ homepage = "https://git.sr.ht/~sircmpwn/gmni";
+ license = licenses.gpl3;
+ maintainers = with maintainers; [ bsima ];
+ platforms = platforms.all;
+ };
+}