summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/perscache.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps/perscache.nix')
-rw-r--r--Biz/Bild/Deps/perscache.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/Biz/Bild/Deps/perscache.nix b/Biz/Bild/Deps/perscache.nix
deleted file mode 100644
index 508a261..0000000
--- a/Biz/Bild/Deps/perscache.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ lib, sources, buildPythonPackage, beartype, cloudpickle, icontract, pbr }:
-
-buildPythonPackage rec {
- pname = "perscache";
- version = sources.perscache.rev;
-
- src = sources.perscache;
-
- propagatedBuildInputs = [ beartype cloudpickle icontract pbr ];
- PBR_VERSION = version;
-
- doCheck = false; # no tests currently
- pythonImportsCheck = [ "perscache" ];
-
- meta = with lib; {
- description = ''
- An easy to use decorator for persistent memoization: like
- `functools.lrucache`, but results can be saved in any format to any
- storage.
- '';
- homepage = "https://github.com/leshchenko1979/perscache";
- license = licenses.mit;
- maintainers = with maintainers; [ bsima ];
- };
-}