summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Hardware.nix')
-rw-r--r--Biz/Cloud/Hardware.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/Biz/Cloud/Hardware.nix b/Biz/Cloud/Hardware.nix
index 20eab30..ab775dc 100644
--- a/Biz/Cloud/Hardware.nix
+++ b/Biz/Cloud/Hardware.nix
@@ -1,8 +1,7 @@
-{ ... }:
+{ modulesPath, ... }:
{
+ imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
boot.loader.grub.device = "/dev/vda";
+ boot.initrd.kernelModules = [ "nvme" ];
fileSystems."/" = { device = "/dev/vda1"; fsType = "ext4"; };
- swapDevices = [
- { device = "/swapfile"; } # 4GB
- ];
}