summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Mail.nix')
-rw-r--r--Biz/Cloud/Mail.nix54
1 files changed, 0 insertions, 54 deletions
diff --git a/Biz/Cloud/Mail.nix b/Biz/Cloud/Mail.nix
deleted file mode 100644
index fa99cf3..0000000
--- a/Biz/Cloud/Mail.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-{ ... }:
-
-/* Known issues:
-
- - when the acme cert gets refreshed, you need to manually restart dovecot
- - when restarting dovecot, it might hang, in that case do:
- systemctl --job-mode=ignore-dependencies restart dovecot2 postfix
-*/
-
-{
- mailserver = {
- enable = true;
- monitoring = {
- enable = false;
- alertAddress = "bsima@me.com";
- };
- fqdn = "simatime.com";
- domains = [ "simatime.com" "bsima.me" ];
- certificateScheme = 3; # let's encrypt
- enableImap = true;
- enablePop3 = true;
- enableImapSsl = true;
- enablePop3Ssl = true;
- enableManageSieve = true;
- virusScanning = false; # ur on ur own
- localDnsResolver = true;
-
- loginAccounts = {
- "ben@simatime.com" = {
- hashedPasswordFile = "/home/ben/hashed-mail-password";
- aliases = [
- # my default email
- "ben@bsima.me"
- # admin stuff
- "postmaster@simatime.com"
- "abuse@simatime.com"
- ];
- catchAll = [ "simatime.com" "bsima.me" ];
- quota = "10G";
- };
- "dev@simatime.com" = {
- hashedPasswordFile = "/home/ben/hashed-mail-password";
- aliases = [ "dev@bsima.me" ];
- quota = "10G";
- };
- "nick@simatime.com" = {
- hashedPassword =
- "$6$31P/Mg8k8Pezy1e$Fn1tDyssf.1EgxmLYFsQpSq6RP4wbEvP/UlBlXQhyKA9FnmFtJteXsbJM1naa8Kyylo8vZM9zmeoSthHS1slA1";
- aliases = [ "nicolai@simatime.com" ];
- quota = "1G";
- };
- };
- };
-}