summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Networking.nix')
-rw-r--r--Biz/Cloud/Networking.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/Biz/Cloud/Networking.nix b/Biz/Cloud/Networking.nix
index b259d86..4c8e058 100644
--- a/Biz/Cloud/Networking.nix
+++ b/Biz/Cloud/Networking.nix
@@ -1,9 +1,21 @@
{ lib, config, ... }:
-{
+let
+ ports = {
+ ssh = 22;
+ http = 80;
+ https = 443;
+ sabten = 8080;
+ };
+in {
networking = {
firewall = {
- allowedTCPPorts = [ 22 80 443 ];
+ allowedTCPPorts = [
+ ports.ssh
+ ports.http
+ ports.https
+ ports.sabten
+ ];
};
nameservers = [
"67.207.67.2"