summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix22
1 files changed, 17 insertions, 5 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index bc0d921..cba8b2f 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -12,10 +12,10 @@ in
listen = "0.0.0.0:1965 [::]:1965";
":tls" = { store = "/var/lib/gmnisrv"; };
"bsima.me" = {
- "root" = "/www/ben/public";
+ "root" = "/srv/www/ben";
};
"simatime.com" = {
- "root" = "/www/simatime.com/public";
+ "root" = "/srv/www/simatime.com";
"cgi" = "on";
};
};
@@ -34,11 +34,23 @@ in
virtualHosts = {
${rootDomain} = {
- locations."/".root = "/srv/www/";
+ locations."/archive.*" = {
+ root = "/srv/www/simatime.com/archive";
+ extraConfig = ''
+ autoindex on;
+ '';
+ };
+
+ locations."/" = {
+ root = "/srv/www/simatime.com";
+ extraConfig = ''
+ autoindex on;
+ '';
+ };
# serve /~$USER paths
locations."~ ^/~(.+?)(/.*)?$" = {
- alias = "/www/$1/public$2";
+ alias = "/srv/www/$1$2";
index = "index.html index.htm";
extraConfig = ''
autoindex on;
@@ -50,7 +62,7 @@ in
"bsima.me" = {
locations."/" = {
- root = "/www/ben/public";
+ root = "/srv/www/ben";
index = "index.html index.htm";
extraConfig = ''
autoindex on;