summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 373af96..5f4789a 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -195,6 +195,12 @@ in
};
};
+ "music.${rootDomain}" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ locations."/".proxyPass = "http://localhost:${toString ports.botamusique}";
+ };
+
"notebook.${rootDomain}" = {
forceSSL = true;
useACMEHost = rootDomain;
@@ -224,6 +230,7 @@ in
"dragons.dev"
"nixpert.chat"
] ++ map (sub: "${sub}.${rootDomain}") [
+ "music"
"tv"
"matrix"
"chat"