summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 87a75da..2b3fd12 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -20,6 +20,22 @@ in
};
services = {
+
+ libreddit = {
+ enable = true;
+ address = "127.0.0.1";
+ openFirewall = true;
+ port = ports.libreddit;
+ };
+
+ invidious = {
+ enable = true;
+ database.createLocally = true;
+ domain = "youtube.${rootDomain}";
+ nginx.enable = false; # do this myself, below
+ port = ports.invidious;
+ };
+
radicale = {
enable = true;
settings = {
@@ -119,6 +135,33 @@ in
useACMEHost = rootDomain;
};
+ "reddit.${rootDomain}" = {
+ locations."/".proxyPass = "http://localhost:${toString ports.libreddit}";
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ };
+ "www.reddit.${rootDomain}" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ globalRedirect = "reddit.${rootDomain}";
+ };
+ "old.reddit.${rootDomain}" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ globalRedirect = "reddit.${rootDomain}";
+ };
+
+ "youtube.${rootDomain}" = {
+ locations."/".proxyPass = "http://localhost:${toString ports.invidious}";
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ };
+ "www.youtube.${rootDomain}" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ globalRedirect = "youtube.${rootDomain}";
+ };
+
"devalloc.io" = {
forceSSL = true;
useACMEHost = rootDomain;
@@ -189,5 +232,10 @@ in
"sabten"
"cal"
"notebook"
+ "reddit"
+ "old.reddit"
+ "www.reddit"
+ "youtube"
+ "www.youtube"
];
}