summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index c699b1b..87a75da 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -44,7 +44,7 @@ in
"bsima.me" = {
"root" = "/var/web/ben";
};
- "simatime.com" = {
+ "${rootDomain}" = {
"root" = "/var/web/simatime.com";
"cgi" = "on";
};
@@ -143,7 +143,16 @@ in
useACMEHost = rootDomain;
};
- "notebook.simatime.com" = {
+ "sd.${rootDomain}" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ locations."/" = {
+ proxyPass = "http://${ports.bensIp}:${toString ports.stableDiffusion}";
+ proxyWebsockets = true;
+ };
+ };
+
+ "notebook.${rootDomain}" = {
forceSSL = true;
useACMEHost = rootDomain;
locations = {