summaryrefslogtreecommitdiff
path: root/Biz/Cloud/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/git.nix')
-rw-r--r--Biz/Cloud/git.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/Biz/Cloud/git.nix b/Biz/Cloud/git.nix
new file mode 100644
index 0000000..370f52a
--- /dev/null
+++ b/Biz/Cloud/git.nix
@@ -0,0 +1,17 @@
+{ pkgs, ... }:
+
+{
+ services = {
+ gitolite = {
+ enable = true;
+ enableGitAnnex = true;
+ dataDir = "/srv/git";
+ user = "git";
+ group = "git";
+ extraGitoliteRc = ''
+ $RC{SITE_INFO} = 'a computer is a bicycle for the mind.';
+ '';
+ adminPubkey = builtins.readFile ../keys/ben.pub;
+ };
+ };
+}