summaryrefslogtreecommitdiff
path: root/Biz/Dev/Configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Dev/Configuration.nix')
-rw-r--r--Biz/Dev/Configuration.nix22
1 files changed, 14 insertions, 8 deletions
diff --git a/Biz/Dev/Configuration.nix b/Biz/Dev/Configuration.nix
index 2dcc816..8eb4958 100644
--- a/Biz/Dev/Configuration.nix
+++ b/Biz/Dev/Configuration.nix
@@ -5,7 +5,7 @@ let
ports = import ../Cloud/Ports.nix;
in {
networking = {
- nameservers = [ "1.1.1.1" "8.8.8.8" ];
+ nameservers = [ "1.1.1.1" ];
hostName = "lithium";
hosts = {
"::1" = [ "localhost" "ipv6-localhost" "ipv6-loopback" ];
@@ -13,17 +13,22 @@ in {
firewall = {
allowedTCPPorts = [
- 22 8000 8443 443 # standard ports
- 500 10000 # no idea
- ports.jellyfin
+ ports.bitcoind
ports.delugeWeb
- ports.murmur
+ ports.et
+ ports.gemini
+ ports.git
+ ports.http
+ ports.https
+ ports.jellyfin
+ ports.jupyter
ports.mpd
ports.mpd-stream
+ ports.murmur
+ ports.radicale
+ ports.sabten
+ ports.ssh
ports.tor
- ports.et
- ports.bitcoind
- ports.jupyter
];
allowedTCPPortRanges = [
ports.torrents
@@ -61,6 +66,7 @@ in {
environment.systemPackages = [
pkgs.wemux
pkgs.tmux
+ pkgs.wireguard
];
nixpkgs = {