summaryrefslogtreecommitdiff
path: root/Biz/Ibb/service.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Ibb/service.nix')
-rw-r--r--Biz/Ibb/service.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/Biz/Ibb/service.nix b/Biz/Ibb/service.nix
new file mode 100644
index 0000000..f9d0f36
--- /dev/null
+++ b/Biz/Ibb/service.nix
@@ -0,0 +1,42 @@
+{ options
+, lib
+, config
+, pkgs
+, modulesPath
+}:
+
+let
+ cfg = config.services.ibb;
+in
+{
+ options.services.ibb = {
+ enable = lib.mkEnableOption "Enable the IBB service";
+ port = lib.mkOption {
+ type = lib.types.string;
+ default = "3000";
+ description = ''
+ The port on which IBB will listen for
+ incoming HTTP traffic.
+ '';
+ };
+ };
+ config = lib.mkIf cfg.enable {
+ systemd.services.ibb = {
+ path = with pkgs; [ ibb bash ];
+ wantedBy = [ "multi-user.target" ];
+ script = ''
+ PORT=${cfg.port} ./bin/ibb
+ '';
+ description = ''
+ Influenced By Books website
+ '';
+ serviceConfig = {
+ WorkingDirectory = pkgs.ibb;
+ KillSignal = "INT";
+ Type = "simple";
+ Restart = "on-abort";
+ RestartSec = "10";
+ };
+ };
+ };
+}